Setup and Tools

The first step to using Flutter is installing the Flutter SDK, which will also install Dart. Follow this super in-depth guide to get started: Flutter.io Getting Started Guide.

Choose an Editor with Dart Plugins

You can use whichever text editor you'd like to write Dart code, but you'll have a much more productive experience if you choose an IDE with Flutter support. These are the two that I'd suggest:

1. IntelliJ Idea

I highly recommend JetBrains Intellij IDEA. The community edition is free.

This IDE will give you all the nice features you'd want for any language: code completion, snippets, error highlighting, linting, etc. You'll also get killer debugging features. There's a browser-dev-tools style Inspector and more in the debug tools.

In order to use IntelliJ, you'll need to install the Dart and Flutter plugins within IntelliJ.

flutter inspector

Flutter inspector showing the widget tree -- similar to view HTML in browser dev tools.

2. VS Code

The Dart community has built a Dart plugin for VS code which has Flutter feature support. It won't be as robust, but it's a fine alternative.

Pub and Libraries

pub is the Dart package management system. There's a website where can browse, search and get info about all the available packages for Dart and Flutter.

Dart Pub Packages

Gitter

If you run into any problems, you can ask for help in real time on the Flutter Gitter Channel. There you'll find Flutter team members from Google as well as a supportive community of fans.

Flutter Docs

Finally, I sincerely find Flutter's documentation is among the best I've come across: Flutter Widget Docs